Bienvenue sur le forum !

Si vous souhaitez rejoindre la communauté, cliquez sur l'un de ces boutons !

Qt 5 : 5.9.1 - Qt Creator : 4.3.1 - Qt Installer : 2.0.3 - JOM : 1.1.2 - Qt Build suite : 1.7.0 - VS Qt 5 : 2.0.0

Problème de connexion à serveur OpenSSL

Bonjour,

Je réalise pour la première fois une application mobile avec Qt 5.8. Je reprends un projet existant.
Je débugue sur mon téléphone (Samsung Galaxy S5 SM-G901F avec Android 6.0.1)

Sur ce projet, je dois me connecter à un serveur en OpenSSL. J'utilise OpenSSL 1.0.2k sous Windows.
Lorsque je compile le projet à l'aide de MSVC2015 sous Qt Creator, pas de pb de connexion.
Mais lorsque je compile ce projet pour Android et l'exécute sur mon téléphone, impossible de se connecter (paramètres Diffie-Hellman non valides).

Je voulais tenter de recompiler OpenSSL pour intégrer les .so directement dans l'APK.
J'ai suivi le tuto suivant : http://doc.qt.io/qt-5/opensslsupport.html en espérant qu'il fonctionne car c'est pour Qt 5.9.
J'ai installé MSYS-1.0.11 et perl 5.26 et essayé de recompiler les sources d'openSSL 1.0.2h compatibles avec Qt 5.8.
Malheureusement, je bloque sur la dernière étape :
image

Est-ce que quelqu'un a déjà tenté de recompiler ces bibliothèques ?
Est-ce la bonne solution pour résoudre mon problème ?
Y'a-t-il incompatibilité entre les composants que j'ai installé ?

L'ancien programmeur m'a dit qu'il arrivait à se connecter au serveur avec le téléphone HTC One qu'il avait, sans inclure ces bibliothèques dans l'APK.
J'ai récupéré le téléphone mais malheureusement, je ne peux pas m'en servir car il n'est pas détecté par mon ordinateur.
Le HTC One possède Android 5.0.2
Est-ce que ça pourrait venir de là ?
Connectez-vous ou Inscrivez-vous pour répondre.