Bienvenue sur le forum !

Si vous souhaitez rejoindre la communauté, cliquez sur l'un de ces boutons !

Qt 5 : 5.9.1 - Qt Creator : 4.4.0 - Qt Installer : 2.0.3 - JOM : 1.1.2 - Qt Build suite : 1.7.0 - VS Qt 5 : 2.0.0

Mon application en se lance pas sur mon smartphone

Bonjour,

Voilà j'ai un smartphone sur Android en 4.2.1 et je génère mon application en 4.1.2 (je me dis que si je génère en version inférieur sa devrait marcher pour la mienne :/ )

Du coup lorsque je lance avec Qt sur AVD ça fonctionne niquel l'application se lance et fonctionne.

Mais quand je récupère l'apk: QtApp.apk dans : monDossier/android-build-bin
Et que je l'installe sur mon téléphone, sa reste sur écran noir et rien ne se lance...

Je fais peut-être une fausse manip?

Réponses

  • Si c'est pour tester ton application, le plus simple est d'activer le mode developpeur et de connecter l'appareil a ton ordi. Qt Creator lancera directement dessus
    Si la question est le deploiment, il faut verifier les dependances. Regarde dans le mode Projects, tu as des options de deploiment des libs Qt. Il est possible que ton application ne fonctionne pas parce qu'elle ne trouve pas les libs. Test en incluant les libs Qt dans le paquet
  • J'ai activé le mode développeur mais je fais comment pour lancer dessus?

    Parce que quand je veux lancer j'ai :
    image

    Et mes paramètres de projet:

    image
  • J'ai réussi à compiler avec mon téléphone, mais toujours un black screen...
    J'ai ce message d'erreur dans la sortie d'application lorsque je touche l'écran:

    W/Choreographer(31611): Frame time is 0.219681 ms in the future! Check that graphics HAL is generating vsync timestamps using the correct timebase.
  • Bonjour,
    La documentation conseille de sélectionner l'API level la plus élevée: doc
    Selecting API Level
    In the Android target SDK field, you can select the API level to use for building the application. Usually, you should select the newest API level available.
    This field does not specify the minimum supported API level nor the target API level, which you can specify in the Android manifest file. For more information about Android API levels, see What is API Level?.


    Donc dans ton cas choisi plutôt > 4.2.1

    Sinon crée un programme des plus basiques, style "Hello World" et re-test le déploiement.
    Si cela fonctionne, commente des portions de ton code pour localiser la portion qui pose problème si ton appli est complexe.
Connectez-vous ou Inscrivez-vous pour répondre.