Bienvenue sur le forum !

Si vous souhaitez rejoindre la communauté, cliquez sur l'un de ces boutons !

Qt 5 : 5.9.1 - Qt Creator : 4.4.0 - Qt Installer : 2.0.3 - JOM : 1.1.2 - Qt Build suite : 1.7.0 - VS Qt 5 : 2.0.0

QWebview et taille des scrollbars

Bonjour,

Comme écrit dans le titre, je ne parviens pas à modifier la taille des scrollbars de ma QWebview.

Si quelqu'un pouvait m'indiquer comment faire cela.

Merci par avance

Réponses

  • J'ai trouvé un bout de code qui semble résoudre le problème mais ca fait beaucoup de ligne pour si peu. Il n'y a vraiment pas une manière de faire cela comme avec les Stylesheet?!

    #include <QtGui>
    #include <QWebView>

    class Style : public QWindowsStyle
    {
    public:
    Style()
    {
    }
    int pixelMetric ( PixelMetric metric, const QStyleOption * option = 0, const QWidget * widget = 0 ) const
    {
    if (metric == QStyle::PM_ScrollBarExtent && widget == 0)
    return 30;
    return QWindowsStyle::pixelMetric(metric, option, widget);
    }

    };
    class WebView : public QWebView
    {
    public:
    WebView()
    {
    qApp->setStyle(new Style());
    load(QUrl("http://qt.nokia.com/doc/4.5/qwebview.html";));
    QTimer::singleShot(5000, this, SLOT(testSlot()));
    }

    };

    int main(int argc, char **argv)
    {
    QApplication app(argc, argv);
    WebView view;
    view.show();
    return app.exec();
    }
    le lien:
    http://developer.qt.nokia.com/faq/answer/how_can_i_change_the_width_of_the_scrollbar_of_qwebview
  • Justement j'ai essayé de faire comme cela car j'ai réussi à agrandir des scrollbars dans des scrollAreas en faisant comme ceci:
    scrollArea->setStyleSheet("QScrollBar:vertical {width: 35px;}");
    C'est pourquoi j'ai tenté de faire de même avec ma QWebview mais quelque soit le paramètre, ca n'affecte pas la scrollbar en question. J'ai l'impression que la scrollbar que j'essaie d'atteindre soit dans la QWebview et non pas celle de la QWebview (je sais pas si c'est clair ce que je raconte!? :) ).
Connectez-vous ou Inscrivez-vous pour répondre.